Libvirt / QEMU / KVM Reference

Anytime I have to browse the web for some sort of reference on using some particular piece of software, I try to make it a point to record it for later. Since the name of it in totality is a bit dubious to me (feel free to straighten me out), I just listed all the names I know it by.

The Problem

I set up a VM using QEMU/KVM Session as opposed to QEMU/KVM User Session and would you know it, it just wouldn’t launch. The error:

Error starting domain: Requested operation is not valid: network ‘default’ is not active

After some web searching I learned that the ‘default’ NAT network is created by the libvirtd daemon. To check that in terminal:

sudo virsh net-list --all

That gave me this output:

Name      State      Autostart   Persistent
----------------------------------------------
default   inactive   no          yes

Under the status section I see that it is inactive, which is clearly the reason for the failure to launch. The fix:

sudo virsh net-start default

Running the net-list command again reveiled

Name      State    Autostart   Persistent
--------------------------------------------
default   active   no          yes

Enable Autostart

To ensure that I don’t have problems next time and I can forget how I did any of this, here is the solution. In terminal:

sudo virsh net-autostart default

That will return:

Network default marked as autostarted

I can now verify that to be true by using the previously stated net-list command that it Autostart is enabled.

Final Thoughts

The Virtual machine launched after I started the default interface so I know that the information taken from this site works for my system. This site also lays it out much better but in an effort to remember this process. I have written down here and linked it to there for future reference. So, should my virt-manager break again, I can click to see what the more experienced folk know.

References

Ask Xmodulo, How to fix “network ‘default’ is not active” error in libvirt